第16章 メニュー

目次

1. メニューのあらまし
1.1. 画像ウィンドウのメニューバー
1.2. 脈絡メニュー
1.3. 切り取り可能なメニュー
1.4. タブメニュー
2. 「ファイル」メニュー
2.1. 概観
2.2. New
2.3. Create
2.4. Open
2.5. Open as Layers
2.6. Open Location
2.7. Open Recent
2.8. Save
2.9. Save as
2.10. Save a Copy
2.11. Revert
2.12. Export
2.13. Export As...
2.14. Create Template
2.15. Print
2.16. Close
2.17. Close all
2.18. Quit
3. 「編集」メニュー
3.1. 「Edit」 Menu Entries
3.2. Undo
3.3. Redo
3.4. Fade
3.5. Undo History
3.6. Cut
3.7. Copy
3.8. Copy Visible
3.9. Paste
3.10. Paste Into
3.11. Paste as
3.12. Buffer
3.13. Clear
3.14. Fill with FG Color
3.15. Fill with BG Color
3.16. Fill with Pattern
3.17. Stroke Selection
3.18. Stroke Path
3.19. The 「Preferences」 Command
3.20. Keyboard Shortcuts
3.21. Modules
3.22. Units
4. 「選択」メニュー
4.1. 「選択」メニューのあらまし
4.2. Select All
4.3. None
4.4. Invert
4.5. Float
4.6. By Color
4.7. From Path
4.8. Selection Editor
4.9. Feather
4.10. Sharpen
4.11. Shrink
4.12. Grow
4.13. Border
4.14. Distort
4.15. Rounded Rectangle
4.16. Toggle QuickMask
4.17. Save to Channel
4.18. To Path
5. 「表示」メニュー
5.1. Introduction to the 「View」 Menu
5.2. New View
5.3. Dot for Dot
5.4. Zoom
5.5. Shrink Wrap
5.6. Full Screen
5.7. Navigation Window
5.8. Display Filters
5.9. Show Selection
5.10. Show Layer Boundary
5.11. Show Guides
5.12. Show Grid
5.13. Show Sample Points
5.14. Snap to Guides
5.15. Snap to Grid
5.16. Snap to Canvas
5.17. Snap to Active Path
5.18. Padding Color
5.19. Show Menubar
5.20. Show Rulers
5.21. Show Scrollbars
5.22. Show Statusbar
6. 「画像」メニュー
6.1. Overview
6.2. Duplicate
6.3. Mode
6.4. RGB mode
6.5. Grayscale mode
6.6. Indexed mode
6.7. Transform
6.8. Flip Horizontally; Flip Vertically
6.9. Rotation
6.10. Guillotine
6.11. Canvas Size
6.12. Fit Canvas to Layers
6.13. Fit Canvas to Selection
6.14. Print Size
6.15. Scale Image
6.16. Crop to Selection
6.17. Autocrop Image
6.18. Zealous Crop
6.19. Merge Visible Layers
6.20. Flatten Image
6.21. Align Visible Layers
6.22. Guides
6.23. New Guide
6.24. New Guide (by Percent)
6.25. New Guides from Selection
6.26. Remove all guides
6.27. Configure Grid
6.28. Image Properties
7. 「レイヤー」メニュー
7.1. Introduction to the 「Layer」 Menu
7.2. New Layer
7.3. New Layer Group
7.4. New From Visible
7.5. Duplicate layer
7.6. Anchor layer
7.7. Merge Down
7.8. Delete Layer
7.9. The Text Commands of the Layer Menu
7.10. Discard Text Information
7.11. 「Stack」 Submenu
7.12. Select Previous Layer
7.13. Select Next Layer
7.14. Select Top Layer
7.15. Select Bottom Layer
7.16. Raise Layer
7.17. Lower Layer
7.18. Layer to Top
7.19. Layer to Bottom
7.20. The 「Reverse Layer Order」 command
7.21. The 「Mask」 Submenu
7.22. Add Layer Mask
7.23. Apply Layer Mask
7.24. Delete Layer Mask
7.25. Show Layer Mask
7.26. Edit Layer Mask
7.27. Disable Layer Mask
7.28. Mask to Selection
7.29. Add Layer Mask to Selection
7.30. Subtract Layer Mask from Selection
7.31. Intersect Layer Mask with Selection
7.32. The 「Transparency」 Submenu of the 「Layer」 menu
7.33. Add Alpha Channel
7.34. Remove Alpha Channel
7.35. Color to Alpha
7.36. Semi-flatten
7.37. Threshold Alpha
7.38. Alpha to Selection
7.39. Add Alpha channel to Selection
7.40. Subtract from Selection
7.41. Intersect Alpha channel with Selection
7.42. The 「Transform」 Submenu
7.43. Flip Horizontally
7.44. Flip Vertically
7.45. Rotate 90° clockwise
7.46. Rotate 90° counter-clockwise
7.47. Rotate 180°
7.48. Arbitrary Rotation
7.49. Offset
7.50. Layer Boundary Size
7.51. Layer to Image Size
7.52. Scale Layer
7.53. Crop to Selection
7.54. Autocrop Layer
8. 「色」メニュー
8.1. Introduction to the 「Colors」 Menu
8.2. Colors Tools
8.3. Invert
8.4. Value Invert
8.5. Use GEGL
8.6. The 「Auto」 Submenu
8.7. 平滑化
8.8. ホワイトバランス
8.9. 色強調
8.10. 正規化
8.11. コントラスト伸長
8.12. HSV 伸長
8.13. The 「Components」 Submenu
8.14. チャンネルミキサー...
8.15. チャンネル合成...
8.16. チャンネル分解
8.17. 再合成
8.18. The 「Map」 Submenu
8.19. インデックスカラーの並べ替え...
8.20. カラーマップを変更...
8.21. エイリアンマップ...
8.22. 色交換...
8.23. グラデーションマップ
8.24. パレットマップ
8.25. カラーマップ回転...
8.26. サンプル色付け...
8.27. The 「Info」 Submenu
8.28. ヒストグラム
8.29. 境界の平均色...
8.30. 色立体分析...
8.31. パレット生成...
8.32. The Color Filters
8.33. Colorify
8.34. Color to Alpha
8.35. Filter Pack
8.36. Hot
8.37. Max RGB
8.38. Retinex
9. 「ツール」メニュー
9.1. 「ツール」メニューのあらまし
10. 「フィルター」メニュー
10.1. Introduction to the 「Filters」 Menu
10.2. Repeat Last
10.3. Re-show Last
10.4. Reset All Filters
10.5. The 「Python-Fu」 Submenu
10.6. The 「Script-Fu」 Submenu
11. 「ウィンドウ」メニュー
12. 「ヘルプ」メニュー
12.1. 「ヘルプ」メニューのあらまし
12.2. Help
12.3. Context Help
12.4. Tip of the Day
12.5. About
12.6. Plug-In Browser
12.7. The Procedure Browser
12.8. GIMP online

1. メニューのあらまし

GIMP にはいたるところにメニューがあります。 この章の目的は、 画像ウィンドウのメニューで呼び出せるコマンドの解説です。 画像メニューは画像ウィンドウのメニューバーをクリックするか、 キャンバスを 第2ボタン でクリックすると開きます。 そのほかダイアログに付属する脈絡メニューやそのメニュー項目は、 個々のダイアログの説明 のなかで解説しています。

1.1. 画像ウィンドウのメニューバー

Script-Fu や Python-Fu のスクリプトを追加したり動画プラグインなどを GIMP に導入した場合、 このメニューバーに新たに別のメニューが加わることもあります。

1.2. 脈絡メニュー

GIMP のインターフェースはその特定部位をマウスの 第2ボタン でクリックするといろいろな機能が入っている脈絡メニューが開きます。 脈絡メニューが出てくる部分はつぎのとおりです。

  • 画像ウィンドウのキャンバス内を 第2ボタン でクリックすると画像ウィンドウのメニューが呼び出せます。 メニューバーを隠してフルスクリーンモードで作業しているときはこの方法が便利です。

  • レイヤーダイアログのレイヤーやチャンネルダイアログのチャンネルなどは 第2ボタン でクリックするとそのダイアログの脈絡メニューが呼び出せます。

  • 画像ウィンドウの左上のメニューボタンをクリックしたり、 F10 キーを押してもメニューが呼び出せます。

  • タイトルバーを 第2ボタン でクリックするとメニューか何かの機能が呼び出されますが、 これは GIMP に属したものではなく、 お使いのコンピューターのウィンドウマネージャーの機能です。

1.3. 切り取り可能なメニュー

GIMP の一部のメニューには面白い特徴が備わっています。 各ダイアログの脈絡メニューや画像ウィンドウメニューのサブメニュー ( の印がサブメニューのあるメニュー項目の右端についていることで判る) はもちろん、 キャンバスを 第2ボタン でクリックすると出てくる親メニューは、 呼び出すとその上辺に破線 (切り取り線) がつきます。 この破線をクリックするとこのメニューは切り離され補助ウィンドウになります。

図16.1 「ウィンドウ」サブメニューとその切り離されたサブメニュー

「ウィンドウ」サブメニューとその切り離されたサブメニュー
「ウィンドウ」サブメニューとその切り離されたサブメニュー

切り取られたメニューは実質的に独立しています。 これは常設になり、 現在活性化している画像にその機能が適用されます。 画像がすべて閉じられてもそのメニューは残ります。 このウィンドウ化したメニューを閉じるには再び破線をクリックするか、 お使いのコンピューターのウィンドウマネージャーのウィンドウを閉じる機能 (よくある例はタイトルバーの端の「×」印をクリック) を利用します。

この切り取りメニューはシングルウィンドウモードでも作成できますが、 メニュー項目をクリックした途端に主ウィンドウが手前に出てきて切り取りメニューを隠してしまうのでマルチウィンドウモードほどには使い勝手がよくありません。

1.4. タブメニュー

下図に示したようなメニューは画像ウィンドウのメニューバーにつながっておらず、 補完を目的に設けられています。

ドッキング可能 なダイアログはいずれも下図に示すようなタブメニューボタンがついています。 このボタンをクリックするとこのタブに特に関連が深い操作のメニューが現われ、 その最初に位置するサブメニューがダイアログの脈絡メニューです。

図16.2 ドッキング可能なダイアログ

ドッキング可能なダイアログ

ダイアログのタブメニューボタンを強調

ドッキング可能なダイアログ

タブメニュー


タブメニューの扱い方については 「タブメニュー」 をご覧ください。